Mac VST 64bit doesn't load protected 3rd party libraries

Serious issues
gege
User Level VI
User Level VI
Posts: 61
Joined: Wed Feb 27, 2013 4:37 pm

Mac VST 64bit doesn't load protected 3rd party libraries

Post by gege » Fri Mar 01, 2013 2:38 am

Hi,


testing Nebula Server 3 on Mac with the 64bit VST (for example in Reaper 64bit), it does not load any protected third party lib (for example my Mammoth EQ, Fate Comp and Fate EQ).


They all work in 32bit, the .ser and auth files are in the right place and all work apart from VST 64bit.


As a test I also tried deleting the .ser and authorization files to see if Nebula was creating a new .ser, but the VST 64bit on Mac does not create any .ser


Looks like something is screwed? I need to use my paid 3rd party libraries also on 64bit hosts on Mac.

User avatar
cpwade
Vip Member
Vip Member
Posts: 365
Joined: Thu Dec 30, 2010 5:42 pm
Location: Colorado
Contact:

Re: Mac VST 64bit doesn't load protected 3rd party libraries

Post by cpwade » Fri Mar 01, 2013 2:52 am

It's true. All of my Libs from AITB don't work in 64 on mac. Great on 32. I let it go assuming there would be an update eventually for the 64 osx. I even tried reauthorizing.

Everything other lib works fine.
For me less of an issue, as I bridge to Protools using 32.

I did a batch process in Izotope RX (64 bit) the other day and remembered the problem then I tried to load Doc Fear and Mammoth.

Thanks for mentioning it.
OS X 10.12 | Pro Tools | Logic | Nebula | Gibson | Marshall | Vintage outboard gear that's noisy & hot |
http://paulwade.net
http://paulwade3.wix.com/paulwade
http://www.facebook.com/bratkatrecords
http://www.facebook.com/SummerwindDirective/

gege
User Level VI
User Level VI
Posts: 61
Joined: Wed Feb 27, 2013 4:37 pm

Re: Mac VST 64bit doesn't load protected 3rd party libraries

Post by gege » Sat Mar 02, 2013 9:14 pm

I got a reply from AA and it seems something was 'left behind' when they updated to 64bit..

So they need to send some updated code for the 3rd party developers..at the moment it seems the ETA is within this year (!)

I'm a bit surprised at the moment as it's a quite big issue for professionals working at 64bit..and most of all because we talk about probably the most well known library.

I'll update here as soon as there are any updates..maybe we should all together write here and verify on our systems if it's this way also on Windows? From what they say should be common to all 64bit versions.

User avatar
scooter
Member
Member
Posts: 214
Joined: Fri Apr 02, 2010 8:24 pm
Location: Salt Lake City, Utah
Contact:

Re: Mac VST 64bit doesn't load protected 3rd party libraries

Post by scooter » Tue Jul 23, 2013 9:26 pm

Any updates to this?
My AITB libraries aren't loading at all, after upgrading to Nebula Pro 3 Server edition 1.3.502, using OSX 10.8.4. Using Cubase6/Reaper
-Scott

gege
User Level VI
User Level VI
Posts: 61
Joined: Wed Feb 27, 2013 4:37 pm

Re: Mac VST 64bit doesn't load protected 3rd party libraries

Post by gege » Wed Jul 24, 2013 12:14 am

If you go back to my posts, you'll see that latest Nebula Server VST for Mac has two main problems, and one of those is that old protected libraries (like AITB) don't load at all.

Giancarlo is aware of the problem and AITB too, it seems it not really simple to solve it quickly because they'll need to upgrade a tool for AITB and AITB will need to re-encode/protect all its libraries in this way.

Hopefully we'll have some news soon from Giancarlo and AITB.

User avatar
scooter
Member
Member
Posts: 214
Joined: Fri Apr 02, 2010 8:24 pm
Location: Salt Lake City, Utah
Contact:

Re: Mac VST 64bit doesn't load protected 3rd party libraries

Post by scooter » Wed Jul 24, 2013 7:49 pm

Simple solution, in the interim, would be to give users version, who have purchased an AITB library, that doesn't require an AUTH/protection. I have the older 1073 and DW Fern libraries that were Pre-Auth versions, but I miss that I can't use my compressors(N**e/S*L), EAR, Mammoth and new A*I libraries. Real bummer because I was enjoying working at 44.1khz again, since these libraries sound so great.
-Scott

User avatar
analoginthebox.com
User Level XI
User Level XI
Posts: 155
Joined: Mon Apr 12, 2010 2:34 am

Re: Mac VST 64bit doesn't load protected 3rd party libraries

Post by analoginthebox.com » Wed Jul 31, 2013 5:15 pm

We received updated Keys from Giancarlo!!!

I can't give any ETA yet, but we will start upgrading all libraries for Mac 64Bit compatibility. Starting next week.
At the same time we'll do some maintenance and improve things performance wise. :)

User avatar
enriquesilveti
Expert
Expert
Posts: 2858
Joined: Sun Mar 28, 2010 9:00 pm
Location: Lodi | Madrid | Buenos Aires
Contact:

Re: Mac VST 64bit doesn't load protected 3rd party libraries

Post by enriquesilveti » Thu Aug 01, 2013 10:05 am

analoginthebox.com wrote:We received updated Keys from Giancarlo!!!

I can't give any ETA yet, but we will start upgrading all libraries for Mac 64Bit compatibility. Starting next week.
At the same time we'll do some maintenance and improve things performance wise. :)
Nice!
Enrique Silveti.
Acustica Audio customer and technical support.

MBP 11.5 (i7-4870 | 16 GB | 512 SSD)
SP4 (i5-6300 | 8 GB | 256 SSD)
UFX | Lyra2 | USBPre2
VM U16 | VM Win10 CU | VM OSX 10.12
N4/NAT4 | SPX3 | RX6 | LN2C | Smaart8 | R5 | PT12 | PX10 | NIK5

User avatar
scooter
Member
Member
Posts: 214
Joined: Fri Apr 02, 2010 8:24 pm
Location: Salt Lake City, Utah
Contact:

Re: Mac VST 64bit doesn't load protected 3rd party libraries

Post by scooter » Tue Sep 03, 2013 2:05 am

Any updates?

I saw the news with AITB, but will we still get a fix? :?

AITB?

Thanks

_Scott
-Scott

User avatar
scooter
Member
Member
Posts: 214
Joined: Fri Apr 02, 2010 8:24 pm
Location: Salt Lake City, Utah
Contact:

Re: Mac VST 64bit doesn't load protected 3rd party libraries

Post by scooter » Mon Dec 02, 2013 7:54 am

Any updates?

Thanks
-Scott

Post Reply