N4 Third Party Library not recognized in N4vst

Tips & tricks, working results, technical support
Post Reply
JMetzler
User Level 0
User Level 0
Posts: 2
Joined: Sun Jun 03, 2018 1:57 pm

N4 Third Party Library not recognized in N4vst

Post by JMetzler » Sun Jun 03, 2018 3:44 pm

Hey, guys,

I bought N4 (Generic FX) yesterday and installed Aquarius, N4 and some libraries of Tim P and Henry Olonga. I copied everything in the right folders, cleared the temp folder and ran reaper.

The problem is that Henry Olongas AYCE in N4 is not displayed in the Finder of N4 vst. Tim P's libraries are working. I've tried everything I can for half a day and I'm officially giving up. Can you help me, please?

Jacob

RJHollins
Expert
Expert
Posts: 3681
Joined: Sun Mar 28, 2010 5:53 pm

Re: N4 Third Party Library not recognized in N4vst

Post by RJHollins » Sun Jun 03, 2018 6:42 pm

C:\Nebula4TempRepository\AlternativeDataPath\HenryOlonga
is this the PATH you used ?
i7-5820k, MSI X99A Plus, 16 GIG Ram, Noctua NH-D14, Win-7 Pro [64-bit], Reaper-64

NVC [Nebula Virtual Controllers]

JMetzler
User Level 0
User Level 0
Posts: 2
Joined: Sun Jun 03, 2018 1:57 pm

Re: N4 Third Party Library not recognized in N4vst

Post by JMetzler » Sun Jun 03, 2018 6:47 pm

Thanks for the reply. No I just threw the files in the regular vector and program folders.

RJHollins
Expert
Expert
Posts: 3681
Joined: Sun Mar 28, 2010 5:53 pm

Re: N4 Third Party Library not recognized in N4vst

Post by RJHollins » Sun Jun 03, 2018 8:53 pm

Well ... based on how N-4's XML file PATHS are specified ... I'd have thought that would work too.

There is a specific FOLDER and PATH for Henry's libraries.

Try moving the PROGRAMS and VECTORS into the appropriate ALTERNATE folder. Then clear the TEMP folder,
and then Load N4 to see if libraries are there. [might take time to re-build the TEMP folder].

let us know.
i7-5820k, MSI X99A Plus, 16 GIG Ram, Noctua NH-D14, Win-7 Pro [64-bit], Reaper-64

NVC [Nebula Virtual Controllers]

User avatar
Henry Olonga
Expert
Expert
Posts: 583
Joined: Wed Mar 31, 2010 1:38 am
Location: Adelaide, South Australia
Contact:

Re: N4 Third Party Library not recognized in N4vst

Post by Henry Olonga » Tue Jun 05, 2018 3:22 am

Hi Jacob,
Sorry to hear about your issues. I have been out of the nebula world since 2015 so I am a bit rusty on troubleshooting. Nebula 4 loads my libraries okay here on my setup so unless something drastic has changed it should work. So be encouraged.

You have a couple of alternatives. As RJHollins has suggested, you may need to get the library path right.

Another thing to consider is making a separate plugin just for my library as it is huge and will slow down the scanning of the rest of the library. It will make your life simpler as well I think. I am on Windows 10 though - cannot help with MAC.

I am assuming you would install with the setup file and not Acquarius to do this as it gives you more control. You get this file by logging in to your account and looking up orders. To the right of the N4 picture in your orders is a 'Download Product' button. Click it to take you to a 'box' page. Download the appropriate legacy installer for your platform. VST, VST3 or AAX. I use VST2 here - or commonly called VST as it allows control as well - you can rename them easily. There may be other ways to do this but the way I have done this is to create a completely separate install path for the nebula repository for example - my main library is installed here F:\nebula4temprepository . If you were doing it on my computer, you could create a new folder like this F:\nebula4HOrepository for example and when prompted by the setup application for a folder location, install N4 there. Then you create a NEW folder in your plugin folder. For example C:\Program Files\VSTPlugIns \HONebula4 . Choose that as your VST location. ( Do this before you start the setup program of course ). Then Rename the VST DLL to say for example N4HenryOlonga.DLL.

Now you can start up your DAW and attempt to scan and run the new plugin. If all goes well you should see your created Nebula4 plugin scan through the library. When you try to run it is should say something like Please authorise this plugin or something to that effect. Authorising is not my domain of course but once the plugin is licensed you should be good to go.


Please let me know how you go. This method ensures there is no cross pollination of Nebula4 installs and the computer sees my library as separate at all times. Once it is done it makes it easier to load, as opposed to having everything in one place and also makes it easier to pick the plugin as well. Also ensure the dictionary is up to date as that helps with my category and hardware names and hints.

Anyone else wish to chip in or correct me here as I am very rusty.. :D

Best wishes
Henry

RJHollins
Expert
Expert
Posts: 3681
Joined: Sun Mar 28, 2010 5:53 pm

Re: N4 Third Party Library not recognized in N4vst

Post by RJHollins » Tue Jun 05, 2018 5:41 am

Hi HenryO. Always good to have you post !

From the OP saying that Libraries are showing/loading with the current N4 installation ... that suggests the 'install' is not the problem.

As it seems only the AYCE libraries are not showing up ...

First thing ... the CATEGORY that Henry's libraries are located in FINDER. Somethings they are in different places. Need to really check the FINDER Folders ...

if not, then I'm thinking where the AYCE library is not installed where N4 knows where to look. Why I suggest using the ALTERNATIVE Path folders [also helps keep directories managed].

now we wait to hear from OP on any of this.
i7-5820k, MSI X99A Plus, 16 GIG Ram, Noctua NH-D14, Win-7 Pro [64-bit], Reaper-64

NVC [Nebula Virtual Controllers]

lucasgoncalves05
User Level 0
User Level 0
Posts: 1
Joined: Fri Oct 27, 2017 1:40 pm

Re: N4 Third Party Library not recognized in N4vst

Post by lucasgoncalves05 » Fri Jun 15, 2018 2:36 am

Hi guys,

I'm having the exact same problem on Mac.

Trying to load Henry's library and nothing shows on N4's finder. I've tried everything above, all different paths, and nothing so far.

Any progress on fixing this?

Thank you!!

RogerB
User Level 0
User Level 0
Posts: 3
Joined: Fri Jun 22, 2018 10:54 pm

Re: N4 Third Party Library not recognized in N4vst

Post by RogerB » Sat Jun 23, 2018 3:24 pm

Is the AlternativeDataPath recognized at all?
When I try to set a path in "Settings" the data path is stored only until I close the last instance of N4.
When I now open a new instance, N4 doesn't remember the path.

The N4.XML in "...VSTplugins" isn't changed at all since installation time and has the date 10.04.2018 16:45.

On Windows 10 there are some side effects connected to security measures. Thus it is necessary to have admin rights in some paths e.g. "C:\Program File\ ...". But it doesn't matter if I start the DAW as an Admin. N4 just doesn't write anything to N4.XML (AND there is no other N4.XML on my system).

In the registry HKLM\Acustica Audio\ (and also under HKCU\Acustica Audio\Nebula ) there is stored the N4TempRepository path. They aren't changed as well when I add a AlternativeDataPath.

Tested every combination to no avail. :oops:

User avatar
Support
Expert
Expert
Posts: 3418
Joined: Mon Feb 24, 2014 11:33 am
Location: Lodi, Lombardia, Italy.
Contact:

Re: N4 Third Party Library not recognized in N4vst

Post by Support » Sat Jun 23, 2018 8:08 pm

Seems your Windows user account lack of write permissions to write the new alternative(s) path(s) into N4.XML file.
Best regards,
Enrique Silveti.
Acustica Audio customer and technical support
http://www.acustica-audio.com

RogerB
User Level 0
User Level 0
Posts: 3
Joined: Fri Jun 22, 2018 10:54 pm

Re: N4 Third Party Library not recognized in N4vst

Post by RogerB » Sat Jun 23, 2018 9:30 pm

Hi there,
true @support and thank you for your reply, I changed from the original VST path (C:\program files\steinberg\vstplugins) to a more securitywise relaxed path under C:\program data. This way I don't need tu run the DAW as Administrator and am able to cut and past. And 3rdpaty Lib paths are working now. :)
regards
Roger
Last edited by RogerB on Sun Jun 24, 2018 6:04 pm, edited 1 time in total.

RogerB
User Level 0
User Level 0
Posts: 3
Joined: Fri Jun 22, 2018 10:54 pm

Re: N4 Third Party Library not recognized in N4vst

Post by RogerB » Sat Jun 23, 2018 9:30 pm

Hi there,
true @support, I changed from the original VST path (C:\program files\steinberg\vstplugins) to a more securitywise relaxed path under C:\program data. This way I don't need tu run the DAW as Administrator and am able to cut and past. And 3rdpaty Lib paths work now. :)
regards
Roger

User avatar
zabukowski
Expert
Expert
Posts: 1554
Joined: Sun Mar 28, 2010 8:44 pm
Location: Ljubljana, Slovenia
Contact:

Re: N4 Third Party Library not recognized in N4vst

Post by zabukowski » Sun Jun 24, 2018 7:04 pm

RogerB wrote:
Sat Jun 23, 2018 9:30 pm
Hi there,
true @support and thank you for your reply, I changed from the original VST path (C:\program files\steinberg\vstplugins) to a more securitywise relaxed path under C:\program data. This way I don't need tu run the DAW as Administrator and am able to cut and past. And 3rdpaty Lib paths are working now. :)
regards
Roger
The latest Aquarius version should set proper N4.XML permissons when installing N4.

Post Reply