Long load times now happen.

Tips & tricks, working results, technical support
Post Reply
gwp99
User Level 0
User Level 0
Posts: 4
Joined: Sat Aug 27, 2011 11:42 pm

Long load times now happen.

Post by gwp99 » Wed Jan 08, 2014 12:55 am

Win8.1 Reaper-latest, RME UFX

I just installed a 3rd party library (at 96K...I am running at 44.1) (and yes, I tried to correct the problem with the latest N3 Dec(13) version from an N3 Oct(13) version...same version number, but with an updated date?...and same results...

Anyway, loading an instance of Nebula, went from a few seconds, to an unacceptable 30+ seconds "EACH"...with a full compliment of N3 instances in a project, this is now taking an unacceptable amount of time to load a project.

Suggestions?

User avatar
enriquesilveti
Expert
Expert
Posts: 2861
Joined: Sun Mar 28, 2010 9:00 pm
Location: Lodi | Madrid | Buenos Aires
Contact:

Re: Long load times now happen.

Post by enriquesilveti » Wed Jan 08, 2014 10:14 am

Send me an email to enrique.silveti AT acusticaudio.net
Send me your MAST page. Send me a LOG file. Send me a detailed information about your system.

Acustica Audio crash or bug report: http://www.acustica-audio.com/phpBB3/vi ... ?f=7&t=369
Enrique Silveti.
Acustica Audio customer and technical support.

MBP 11.5 (W10 1803 | OSX 10.13.6 | i7-4870 | 16 GB | 512 GB SSD)
SP4 (W10 1903 | i5-6300 | 8 GB | 256 GB SSD)
Digiface Dante | Lyra2 | Rednet AM2
VM U18 | VM W10 1803 | VM OSX 10.13
N4/NAT4 | SPX4 | RX7 | LN2C | SMAART8 | R5 | PT2019 | PX11 | NIK5

User avatar
botus99
Expert
Expert
Posts: 667
Joined: Wed Mar 31, 2010 7:59 pm

Re: Long load times now happen.

Post by botus99 » Wed Jan 08, 2014 9:28 pm

Can't be sure, but my guess is that you've simply installed a lot of libraries. The more libraries you have, the longer Nebula takes to load.

That's where Zabakowski's Nebula Setups tool is invaluable for creating separate plugins for separate libraries (or however you wish to organanize). I'd go on, but like I said, I have no way of knowing for sure that that is actually your cause for the issue.
Win10 / Reaper / i7 6700K / 16gb RAM | ZED-R16 / Digi003 (Revive modded)
N4 - Orange, Blue, Purple, Pearl, Diamond, Ebony, Gold, Navy, Amethyst, Lime, Sand, Pink, Titanium, Aquamarine, Magenta, Coral, Cobalt, Lemon

gwp99
User Level 0
User Level 0
Posts: 4
Joined: Sat Aug 27, 2011 11:42 pm

Re: Long load times now happen.

Post by gwp99 » Wed Jan 08, 2014 9:48 pm

botus99 wrote:Can't be sure, but my guess is that you've simply installed a lot of libraries. The more libraries you have, the longer Nebula takes to load....
thanks botus99 - you are right on the money!

It was the last 3rd party library (which is huge) I installed...and at the same time, updated my Nebula (dumb, I know!)

Removed the 3rd party library and each instance now takes 6 sec, which is a big improvement.

I am curious as to why there isn't a scan file created on an initial scan, that can be read in by each instance of Nebula...it seems that Nebula has to go through all libraries each time an instance is created...can this be?!

User avatar
giancarlo
Founder
Founder
Posts: 11198
Joined: Mon Sep 21, 2009 10:40 pm
Location: Italy

Re: Long load times now happen.

Post by giancarlo » Wed Jan 08, 2014 11:12 pm

you could reduce lading time adding

<FROZENBOOT> 1 </FROZENBOOT>

to your nebula xml file. Remember to restore it to original 0 defaul value next time you want to add a lbrary or it will not be added automatically. On my system nebula loading time is around 1 sec for a 1500 preset library. Frozenboot is supported since version 1.3.600

dwagrimm
User Level IX
User Level IX
Posts: 94
Joined: Fri Jun 10, 2011 1:36 pm

Re: Long load times now happen.

Post by dwagrimm » Thu Jan 09, 2014 12:24 am

giancarlo wrote:you could reduce lading time adding

<FROZENBOOT> 1 </FROZENBOOT>

to your nebula xml file. Remember to restore it to original 0 defaul value next time you want to add a lbrary or it will not be added automatically. On my system nebula loading time is around 1 sec for a 1500 preset library. Frozenboot is supported since version 1.3.600
if I use your frozenboot all libraries are not longer shown or loading in nebula (1.3.602). only the init. if I remove frozenboot all stuff is back. is there a special need information about editing? for me your xml tweak sounds simple to do.

User avatar
botus99
Expert
Expert
Posts: 667
Joined: Wed Mar 31, 2010 7:59 pm

Re: Long load times now happen.

Post by botus99 » Thu Jan 09, 2014 2:15 am

giancarlo wrote:you could reduce loading time adding

<FROZENBOOT> 1 </FROZENBOOT>

to your nebula xml file. Remember to restore it to original 0 default value next time you want to add a library or it will not be added automatically. On my system nebula loading time is around 1 sec for a 1500 preset library. Frozenboot is supported since version 1.3.600
Holy crap that's awesome! Great new feature!
Win10 / Reaper / i7 6700K / 16gb RAM | ZED-R16 / Digi003 (Revive modded)
N4 - Orange, Blue, Purple, Pearl, Diamond, Ebony, Gold, Navy, Amethyst, Lime, Sand, Pink, Titanium, Aquamarine, Magenta, Coral, Cobalt, Lemon

ericus
Member
Member
Posts: 243
Joined: Sun Mar 28, 2010 9:37 pm

Re: Long load times now happen.

Post by ericus » Thu Jan 09, 2014 4:11 am

dwagrimm wrote:
giancarlo wrote:you could reduce lading time adding

<FROZENBOOT> 1 </FROZENBOOT>

to your nebula xml file. Remember to restore it to original 0 defaul value next time you want to add a lbrary or it will not be added automatically. On my system nebula loading time is around 1 sec for a 1500 preset library. Frozenboot is supported since version 1.3.600
if I use your frozenboot all libraries are not longer shown or loading in nebula (1.3.602). only the init. if I remove frozenboot all stuff is back. is there a special need information about editing? for me your xml tweak sounds simple to do.
Please...is it possible to document AND explain those tips? PLEASE !!!!! And I REALLY mean document the process...anything else besides the minimal required version ???

I recently mixed a record using tons of Nebula libs and I still cringe while thinking about the SUPER LONG load times when I wanted to revisit some of those mixes...I've been avoiding using tons of Nebula libs ever since...

I love Nebula but sometimes I have the impression that we're like guinea pigs or something...an earlier post was talking about FREEZEBOOT and now we're talking about FROZENBOOT...wtf ??? Please guys...which one is good?

Un peu de rigueur SVP...

User avatar
enriquesilveti
Expert
Expert
Posts: 2861
Joined: Sun Mar 28, 2010 9:00 pm
Location: Lodi | Madrid | Buenos Aires
Contact:

Re: Long load times now happen.

Post by enriquesilveti » Thu Jan 09, 2014 12:54 pm

<FROZENBOOT> 1 </FROZENBOOT>

Is an (new) undocumented MAST page tag, Giancarlo create it to try to find a workaround about this issue. In the near future MUST to find an easy/elegant solution and this new tag might be obsolete, this is the reason the still undocumented.
Enrique Silveti.
Acustica Audio customer and technical support.

MBP 11.5 (W10 1803 | OSX 10.13.6 | i7-4870 | 16 GB | 512 GB SSD)
SP4 (W10 1903 | i5-6300 | 8 GB | 256 GB SSD)
Digiface Dante | Lyra2 | Rednet AM2
VM U18 | VM W10 1803 | VM OSX 10.13
N4/NAT4 | SPX4 | RX7 | LN2C | SMAART8 | R5 | PT2019 | PX11 | NIK5

ericus
Member
Member
Posts: 243
Joined: Sun Mar 28, 2010 9:37 pm

Re: Long load times now happen.

Post by ericus » Thu Jan 09, 2014 10:53 pm

enriquesilveti wrote:<FROZENBOOT> 1 </FROZENBOOT>

Is an (new) undocumented MAST page tag, Giancarlo create it to try to find a workaround about this issue. In the near future MUST to find an easy/elegant solution and this new tag might be obsolete, this is the reason the still undocumented.
Cool! Thank you for the clarification!

I will try it and let you know the outcome. :mrgreen:

gwp99
User Level 0
User Level 0
Posts: 4
Joined: Sat Aug 27, 2011 11:42 pm

Re: Long load times now happen.

Post by gwp99 » Fri Jan 10, 2014 2:28 am

giancarlo wrote:you could reduce lading time adding

<FROZENBOOT> 1 </FROZENBOOT>

to your nebula xml file. Remember to restore it to original 0 defaul value next time you want to add a lbrary or it will not be added automatically. On my system nebula loading time is around 1 sec for a 1500 preset library. Frozenboot is supported since version 1.3.600
Thanks Giancarlo...load times now down to 8 secs...will try Nebula Setups to reduce even further.

User avatar
giancarlo
Founder
Founder
Posts: 11198
Joined: Mon Sep 21, 2009 10:40 pm
Location: Italy

Re: Long load times now happen.

Post by giancarlo » Fri Jan 10, 2014 10:23 pm

we'll improve it further

User avatar
Shibata
Member
Member
Posts: 210
Joined: Tue Jul 09, 2013 8:06 pm

Re: Long load times now happen.

Post by Shibata » Mon Jan 20, 2014 4:55 pm

gwp99
You can manualy setup you own configuration with zero loading time - only SRC.
Painful thing - when updaiting the new Nebula ver. dll, must be re-config all this again)
1-Dll+Xml per each individual library.jpg
Dll+Xml per each individual library
2-routing to the content folders.jpg
Routing to the content folders
3-how it works and zero loading time - only SRC..jpg
How it looks and works, zero loading time - only SRC.

User avatar
Melon_Jack
Member
Member
Posts: 280
Joined: Thu Apr 01, 2010 12:55 am
Contact:

Re: Long load times now happen.

Post by Melon_Jack » Mon Jan 20, 2014 7:27 pm

Ох чую и задолбался ты создавать эти все папки =))))

To developers: sad, that it's not possible to do the same with AU version in Logic..)
Sorry for my bad english =))

User avatar
Shibata
Member
Member
Posts: 210
Joined: Tue Jul 09, 2013 8:06 pm

Re: Long load times now happen.

Post by Shibata » Mon Jan 20, 2014 8:18 pm

Melon_Jack
Да, есть такое) Особенно, когда планировал юзать небулу вместе с вторым компом, приходилось с каждым апдейтом, все переделывать, параллельно дублируя еще и на слейве +)

Post Reply