Audio Stuttering with Nebula Reverb - Reverbs

Tips & tricks, working results, technical support
kungfujeezus
User Level I
User Level I
Posts: 17
Joined: Fri Apr 02, 2010 9:16 am

Audio Stuttering with Nebula Reverb - Reverbs

Post by kungfujeezus » Wed Jul 06, 2011 2:36 am

Hi everyone, I just upgraded from Nebula 3 to Nebula 3 Pro and then updated to 1.3.499g. When I loaded an old song file that had Nebula 3 reverb - and a reverb setting, it caused all audio to stutter very slowly. I reloaded Nebula 3 reverb and the same reverb preset (Demeter spring reverb) and it still stutters and says CPU is around 62.5%. It never did that before I upgraded, played smoothly, please help, I have to mix my songs!

richie43
Expert
Expert
Posts: 5049
Joined: Fri Feb 04, 2011 8:47 pm
Location: Minnesota, USA
Contact:

Re: Audio Stuttering with Nebula Reverb - Reverbs

Post by richie43 » Wed Jul 06, 2011 3:44 am

Go into the MAST page and check your DSPBUFFER settings and RATE CNV. When I upgraded one or both were dramatically lowered and freaked out my CPU. Hopefully Giancarlo or Enriqusilveti will chime in soon.....
The Sounds of the Hear and Now
http://soundyaudio.com/

kungfujeezus
User Level I
User Level I
Posts: 17
Joined: Fri Apr 02, 2010 9:16 am

Re: Audio Stuttering with Nebula Reverb - Reverbs

Post by kungfujeezus » Wed Jul 06, 2011 3:50 am

Thanks for the reply, I experimented with higher DSP and CNV settings but I still had stuttering, slow and choppy audio and Reaper reported resources being very high.

RJHollins
Expert
Expert
Posts: 3996
Joined: Sun Mar 28, 2010 5:53 pm

Re: Audio Stuttering with Nebula Reverb - Reverbs

Post by RJHollins » Wed Jul 06, 2011 5:23 am

Remember ... when you change the settings, you have to

1. click the 'SAVE' button, and then
2. RE-LOAD Nebula for the new settings to be activated.
i7-5820k, MSI X99A Plus, 16 GIG Ram, Noctua NH-D14, Win-7 Pro [64-bit], Reaper-64

NVC [Nebula Virtual Controllers]

kungfujeezus
User Level I
User Level I
Posts: 17
Joined: Fri Apr 02, 2010 9:16 am

Re: Audio Stuttering with Nebula Reverb - Reverbs

Post by kungfujeezus » Wed Jul 06, 2011 5:56 am

RJHollins,

Thank you, I've had Nebula for over a year but I'm still a newb. Your suggestion worked. I set the buffer to 2048 and saved and that seemed to work. Are there any recommended settings though? Or a way to determine them for my system

RJHollins
Expert
Expert
Posts: 3996
Joined: Sun Mar 28, 2010 5:53 pm

Re: Audio Stuttering with Nebula Reverb - Reverbs

Post by RJHollins » Wed Jul 06, 2011 9:15 am

Hey Great !!

The ONLY setting that MIGHT need changing is the
CNV. It may also be called RateCNV [its' something
I change awhile back ...] Anyway ... what RateCNV does
is give Nebula time to samplerate convert the library
to your working sample rate [96k, 44.1k etc].

In NEBULA's main window, you'll see the samplerates
displayed. The First one [left] shows the original
library sample rate. The second [right] shows your
current session samplerate. IF YOU SEE a FLASHING
arrow pointing at these values, then Nebula has NOT
fully converted the library ... thus the RateCNV needs
to be increased. I think mine is a 9000.
The ONLY drawback to raising this value [if you can
call it that], is that the library will take longer
time to load [the files are HUGH] ... BUT this is
necessary in order to have the library perform according
to specs.

Again ... remember ... click save after changing values,
and then, RE-LOAD Nebula for those settings to be active.

Hope that helps!
i7-5820k, MSI X99A Plus, 16 GIG Ram, Noctua NH-D14, Win-7 Pro [64-bit], Reaper-64

NVC [Nebula Virtual Controllers]

User avatar
giancarlo
Founder
Founder
Posts: 11214
Joined: Mon Sep 21, 2009 10:40 pm
Location: Italy

Re: Audio Stuttering with Nebula Reverb - Reverbs

Post by giancarlo » Wed Jul 06, 2011 9:27 am

richie43 wrote:Go into the MAST page and check your DSPBUFFER settings and RATE CNV. When I upgraded one or both were dramatically lowered and freaked out my CPU. Hopefully Giancarlo or Enriqusilveti will chime in soon.....
well, it's possible the value is too low, it was aimed to a better user experience (latency-wise). Maybe we'll work on a different algorithm. At the moment nebula tries to match the current asio buffer. It works pretty well on new i7 computers and for new users.

steve36
User Level II
User Level II
Posts: 28
Joined: Fri Oct 29, 2010 2:48 pm

Re: Audio Stuttering with Nebula Reverb - Reverbs

Post by steve36 » Wed Jul 06, 2011 9:59 am

If it continues to flash just press reload...I always have to do this (even though my RATE CNV is set to 9000)...I think it has something to do with my 003 rack and it's tendency towards anal retentiveness. :)

Steve

richie43
Expert
Expert
Posts: 5049
Joined: Fri Feb 04, 2011 8:47 pm
Location: Minnesota, USA
Contact:

Re: Audio Stuttering with Nebula Reverb - Reverbs

Post by richie43 » Wed Jul 06, 2011 4:49 pm

giancarlo wrote:
richie43 wrote:Go into the MAST page and check your DSPBUFFER settings and RATE CNV. When I upgraded one or both were dramatically lowered and freaked out my CPU. Hopefully Giancarlo or Enriqusilveti will chime in soon.....
well, it's possible the value is too low, it was aimed to a better user experience (latency-wise). Maybe we'll work on a different algorithm. At the moment nebula tries to match the current asio buffer. It works pretty well on new i7 computers and for new users.

I think that the DSPBUFFER default may be a bit low for some of us unlucky ones that don't yet have an i7. I have a quad-core, but it's not the monster of an i7, so upping this setting has helped quite a bit. Just a tip for others with less-than-nuclear computers!
The Sounds of the Hear and Now
http://soundyaudio.com/

richie43
Expert
Expert
Posts: 5049
Joined: Fri Feb 04, 2011 8:47 pm
Location: Minnesota, USA
Contact:

Re: Audio Stuttering with Nebula Reverb - Reverbs

Post by richie43 » Wed Jul 06, 2011 5:30 pm

RJHollins wrote:Hey Great !!

The ONLY setting that MIGHT need changing is the
CNV. It may also be called RateCNV [its' something
I change awhile back ...]
Not true. DSPBUFFER settings drastically affect CPU loads. As Giancarlo stated, the default on the newer version of Nebula seems to be ideal for a super computer, like an i7. So any CPU less than that can benefit greatly by increasing your DSPBUFFER settings. My Q8400 quad core does pretty well at 2048 or sometimes 4096. For some reason my performance actually starts to decrease again if I go all the way up to 8192.
The Sounds of the Hear and Now
http://soundyaudio.com/

highvoltage
Member
Member
Posts: 235
Joined: Tue Mar 30, 2010 9:44 pm

Re: Audio Stuttering with Nebula Reverb - Reverbs

Post by highvoltage » Thu Jul 07, 2011 1:08 pm

That's why i have 3 different Nebula dll's.
One with 8192, one with 2048, and one 'realtime' with 256 buffers (but faster prograte).

I configured the realtime one that it only loads the clean kernels, so its still mostly 4% cpu on most programs. I use it for compressors, and eq's, and when i only want the color of the tapes.

blandry
User Level VI
User Level VI
Posts: 66
Joined: Fri Mar 25, 2011 1:07 am

Nebula 2 Re: Audio Stuttering with Nebula Reverb - Reverbs

Post by blandry » Wed Jul 20, 2011 4:03 am

Hi. Can I raise the dsp buffer setting in Nebula 2? The reverbs are freaking out, i.e. they don't work. Massive stuttering on my dual core pc.
I looked at the Mast page but could not find anything with dsp buffering.
Thanks,
B

User avatar
enriquesilveti
Expert
Expert
Posts: 2861
Joined: Sun Mar 28, 2010 9:00 pm
Location: Lodi | Madrid | Buenos Aires
Contact:

Re: Audio Stuttering with Nebula Reverb - Reverbs

Post by enriquesilveti » Wed Jul 20, 2011 5:51 pm

Open Nebula master .XML and change the value by hand.
Enrique Silveti.
Acustica Audio customer and technical support.

MBP 11.5 (W10 1803 | OSX 10.13.6 | i7-4870 | 16 GB | 512 GB SSD)
SP4 (W10 1903 | i5-6300 | 8 GB | 256 GB SSD)
Digiface Dante | Lyra2 | Rednet AM2
VM U18 | VM W10 1803 | VM OSX 10.13
N4/NAT4 | SPX4 | RX7 | LN2C | SMAART8 | R5 | PT2019 | PX11 | NIK5

bharris
User Level II
User Level II
Posts: 21
Joined: Thu Jul 29, 2010 5:56 pm

Re: Audio Stuttering with Nebula Reverb - Reverbs

Post by bharris » Sat Nov 19, 2011 3:21 pm

Hi Everyone,

I am having the same problem - bad audio stuttering with Nebula Reverb. However, unlike as indicated in the manual (and apparently as other users here can do), I can't see any settings on my Mast page - I just see Version, Mode, Meters and Colour. Can somebody please help me get to these settings on my Mast page? In addition, if you could please walk me through exactly how to increase this buffer size, I would really appreciate it.

Thanks!

richie43
Expert
Expert
Posts: 5049
Joined: Fri Feb 04, 2011 8:47 pm
Location: Minnesota, USA
Contact:

Re: Audio Stuttering with Nebula Reverb - Reverbs

Post by richie43 » Sat Nov 19, 2011 3:48 pm

bharris wrote:Hi Everyone,

I am having the same problem - bad audio stuttering with Nebula Reverb. However, unlike as indicated in the manual (and apparently as other users here can do), I can't see any settings on my Mast page - I just see Version, Mode, Meters and Colour. Can somebody please help me get to these settings on my Mast page? In addition, if you could please walk me through exactly how to increase this buffer size, I would really appreciate it.

Thanks!
Go to the Mode entry, and change it from simple to guru. One of the updates changed the default, I think for the common user to not be overwhelmed by too many options! :D
Attachments
Neb GUI.gif
Neb GUI.gif (187.22 KiB) Viewed 2633 times
The Sounds of the Hear and Now
http://soundyaudio.com/

Post Reply